summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-02 19:15:35 +0000
committerJoão Figueiredo2021-02-02 19:15:35 +0000
commit56c156bc7e413efdd4d95622dd721a5978bbec9b (patch)
treee75709a90f09d44baf9c27fdcdf4529b771d47ba /PKGBUILD
downloadaur-56c156bc7e413efdd4d95622dd721a5978bbec9b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40ab73596176
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Merged with official ABS calendarsupport PKGBUILD by João, 2021/02/02 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+
+pkgname=calendarsupport-git
+pkgver=5.16.40_r468.g54c1ec4
+pkgrel=1
+pkgdesc="Calendar support library"
+arch=($CARCH)
+url="https://kontact.kde.org"
+license=(LGPL)
+depends=(kholidays-git akonadi-calendar-git akonadi-notes-git pimcommon-git)
+makedepends=(git extra-cmake-modules-git boost)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kdepim-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PIM_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}