summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2017-05-22 01:29:20 -0400
committerEli Schwartz2017-05-22 01:29:20 -0400
commit505bcf817497d1182049240e53f61e343e919f91 (patch)
tree6a61e1390661765503d8c007656618e7fedafe42 /PKGBUILD
parent71ab9e2c57d4524e8c7638cea1a7a947e7591c63 (diff)
downloadaur-505bcf817497d1182049240e53f61e343e919f91.tar.gz
upgpkg: calibre-git 2.85.1.r434.gd2ed90f043-1
- calibre v3 beta has a new depends on python2-msgpack. - Add makedepends on rapydscript-ng which helps build calibre-server faster. - Make the bytecode compilation process cleaner, avoid embedding builddir location.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a298af62c220..0dbb0aad181f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=calibre-git
-pkgver=2.83.0.r73.g002bde26ea
-pkgrel=2
+pkgver=2.85.1.r434.gd2ed90f043
+pkgrel=1
_mathjax_commit=c493143c02f5809b1112af6c5a2c8eab31050118
pkgdesc="Ebook management application, from git"
arch=('i686' 'x86_64')
@@ -18,11 +18,11 @@ url="https://calibre-ebook.com/"
license=('GPL3')
depends=('python2-dateutil' 'python2-cssutils' 'python2-mechanize' 'mtdev'
'podofo' 'poppler' 'libwmf' 'chmlib' 'python2-lxml'
- 'libusbx' 'python2-pillow' 'python2-dnspython'
+ 'libusbx' 'python2-pillow' 'python2-dnspython' 'python2-msgpack'
'python2-pyqt5' 'python2-psutil' 'icu' 'libmtp' 'python2-dbus'
'python2-netifaces' 'python2-cssselect' 'python2-apsw'
'qt5-webkit' 'qt5-svg' 'python2-pygments' 'optipng')
-makedepends=('git' 'qt5-x11extras' 'xdg-utils')
+makedepends=('git' 'qt5-x11extras' 'xdg-utils' 'rapydscript-ng')
optdepends=('ipython2: to use calibre-debug')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -94,6 +94,6 @@ package() {
"${pkgdir}/usr/lib/calibre/calibre/constants.py"
# Compiling bytecode FS#33392
- python2 -m compileall "${pkgdir}/usr/lib/calibre/"
- python2 -O -m compileall "${pkgdir}/usr/lib/calibre/"
+ python2 -m compileall -d '/' "${pkgdir}/"
+ python2 -O -m compileall -d '/' "${pkgdir}/"
}