summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgustawho2022-07-01 23:08:15 -0600
committergustawho2022-07-01 23:08:15 -0600
commit91335f83ec3ed56fae166196bdaf0df85b13be50 (patch)
tree02ee353d005bd4f210f08685d8442b019b9889d6 /PKGBUILD
parent2de166d9d420172707ab9c3f24f4497ad8ef112f (diff)
downloadaur-calindori-git.tar.gz
PKGBUILD format
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d892315ae6c2..23b2749d8c49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=calindori-git
-pkgver=r556.943d0d0
+pkgver=22.06.r3.gc7efaa2
pkgrel=1
pkgdesc="Calendar for Plasma Mobile"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -17,7 +17,10 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ( set -o pipefail
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
+ )
}
build() {
@@ -27,4 +30,4 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
-} \ No newline at end of file
+}