summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2021-01-13 12:05:58 +0100
committerPhilip Goto2021-01-13 12:05:58 +0100
commit662ad4b4bf96bd19f96e3127b98c6a863c43555d (patch)
treed5b10504d1e5b91fa75cdaa9665aed2c93df06d5 /PKGBUILD
parent72aa341288f17896a07c4e1c5722abde668da2d9 (diff)
downloadaur-662ad4b4bf96bd19f96e3127b98c6a863c43555d.tar.gz
Update to 0.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 20 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d0b24ff2c1f..8a08fae51277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,38 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=0.1.9
+pkgver=0.2.0
pkgrel=1
pkgdesc="Phone dialer and call handler"
arch=(i686 x86_64 armv7h aarch64)
url="https://source.puri.sm/Librem5/calls"
license=(GPL3)
-depends=(callaudiod
- feedbackd
- folks
- gom
- libhandy
- libpeas
- modemmanager)
-makedepends=(gobject-introspection
- meson
- vala)
+depends=(
+ callaudiod
+ feedbackd
+ folks
+ gom
+ libhandy
+ libpeas
+ modemmanager
+)
+makedepends=(
+ gobject-introspection
+ meson
+ vala
+)
source=("${url}/-/archive/v${pkgver}/calls-v${pkgver}.tar.gz")
-sha256sums=('1dfb339d1add63cc096deecebd550206e7f01d7a69aa8d7c583ef2b758eb29c4')
+sha256sums=('98c4963b8c69fb0de88aaf0133c7fc483d954d8e487c53e014768ff8f2f4ee12')
build() {
- arch-meson calls-v${pkgver} build -Dtests=false
- meson compile -C build
+ arch-meson calls-v${pkgver} build -Dtests=false
+ meson compile -C build
}
check() {
- meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C build
}