summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2020-11-21 21:57:43 +0100
committerPhilip Goto2020-11-21 21:57:43 +0100
commit72aa341288f17896a07c4e1c5722abde668da2d9 (patch)
tree32c09f9ccf736edde8ec94248dc66db976d20f82 /PKGBUILD
parent5bdcecdc4bf7df1064d96b31401492a36290caac (diff)
downloadaur-72aa341288f17896a07c4e1c5722abde668da2d9.tar.gz
Update to 0.1.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4da61eddd79..3d0b24ff2c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=0.1.8
+pkgver=0.1.9
pkgrel=1
pkgdesc="Phone dialer and call handler"
arch=(i686 x86_64 armv7h aarch64)
url="https://source.puri.sm/Librem5/calls"
license=(GPL3)
-depends=(feedbackd
+depends=(callaudiod
+ feedbackd
folks
gom
libhandy
@@ -16,19 +17,18 @@ depends=(feedbackd
makedepends=(gobject-introspection
meson
vala)
-source=("https://source.puri.sm/Librem5/calls/-/archive/v${pkgver}/calls-v${pkgver}.tar.gz")
-sha256sums=('58fd2c438fadec812a73181fd6b1a79478814bb10bf8153f3b79a4c6271078a9')
-
+source=("${url}/-/archive/v${pkgver}/calls-v${pkgver}.tar.gz")
+sha256sums=('1dfb339d1add63cc096deecebd550206e7f01d7a69aa8d7c583ef2b758eb29c4')
build() {
arch-meson calls-v${pkgver} build -Dtests=false
- ninja -C build
+ meson compile -C build
}
-# check() {
-# ninja -C build test
-# }
+check() {
+ meson test -C build --print-errorlogs
+}
package() {
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
}