summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2023-10-22 14:26:33 +0200
committerCarl Smedstad2023-10-22 14:38:52 +0200
commit9cb94890d74dc400cce05d27e38c0bcbe3830f67 (patch)
tree9977c031d68c35c620833cdd503f1e63babdcbb5 /PKGBUILD
parente09d991e6665c026e1018fbd4fabf9c6e794844a (diff)
downloadaur-9cb94890d74dc400cce05d27e38c0bcbe3830f67.tar.gz
Publish version 45.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD92
1 files changed, 61 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f71c3c0b82d..0a9b6b8384ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,84 @@
-# Maintainer: Yassine Oudjana <y.oudjana@protonmail.com>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Yassine Oudjana <y.oudjana@protonmail.com>
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=43.0
+pkgver=45.0
pkgrel=1
-pkgdesc='Phone dialer and call handler'
+pkgdesc="Phone dialer and call handler"
arch=(x86_64 aarch64)
-url='https://gitlab.gnome.org/GNOME/calls'
+url="https://gitlab.gnome.org/GNOME/calls"
license=(GPL3)
depends=(
- callaudiod
- evolution-data-server
- feedbackd
- folks
- gom
- libhandy
- libpeas
- modemmanager
- sofia-sip
+ callaudiod
+ dconf
+ evolution-data-server
+ feedbackd
+ folks
+ gcc-libs
+ glib2
+ glibc
+ gom
+ gstreamer
+ gtk3
+ hicolor-icon-theme
+ libgee
+ libhandy
+ libmm-glib
+ libpeas
+ libsecret
+ sofia-sip
)
makedepends=(
- git
- gobject-introspection
- meson
- vala
+ meson
+ python-docutils
+ vala
)
+checkdepends=(
+ gst-plugins-bad
+ gst-plugins-base
+ gst-plugins-good
+ gst-plugins-ugly
+)
+
+_libcall_version=0.1.0
+
source=(
- "git+${url}.git#tag=v${pkgver}"
- "git+https://gitlab.gnome.org/World/Phosh/libcall-ui.git"
+ "$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/calls-v$pkgver.tar.gz"
+ "libcall-ui-$_libcall_version::https://gitlab.gnome.org/World/Phosh/libcall-ui/-/archive/v$_libcall_version/libcall-ui-v$_libcall_version.tar.gz"
+ "remove-failing-tests.patch"
)
-b2sums=('SKIP'
- 'SKIP')
+sha256sums=(
+ '60822ecd41a997c93966765648d7d3412a7350613da1310cccee6e27ab3c1035'
+ 'a3dec58c622fb418c69085c4a20c2804058864d8b74f4af751e9c96b3ecafede'
+ 'd4411f7eed3ac49ce78eb04e139ecc213ed02559ed8a8fb2337dca06969aab86'
+)
+
+_archive="$pkgname-v$pkgver"
prepare() {
- cd $pkgname
+ rm -r "$_archive/subprojects/libcall-ui"
+ cp -r libcall-ui-v$_libcall_version "$_archive/subprojects/libcall-ui"
- git submodule init
- git submodule set-url subprojects/libcall-ui "../libcall-ui"
- git -c protocol.file.allow=always submodule update
+ cd "$_archive"
+ patch -Np1 -i "$srcdir/remove-failing-tests.patch"
}
-
build() {
- cd $pkgname
- arch-meson . _build
- ninja -C _build
+ cd "$_archive"
+
+ arch-meson . build
+ meson compile -C build
+}
+
+check() {
+ cd "$_archive"
+
+ meson test -C build --print-errorlogs
}
package() {
- cd $pkgname
+ cd "$_archive"
- DESTDIR="${pkgdir}" ninja install -C _build
+ meson install -C build --destdir "$pkgdir"
}