summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2022-03-24 13:59:42 +0100
committerPhilip Goto2022-03-24 13:59:42 +0100
commita2fd23de4a3d8a4da44f2d5d1ed9c8143edebe14 (patch)
tree50a4e118e53a564c8231078566a58ed4ca6e1637 /PKGBUILD
parent714f1c192d8927dab5a9dc1a56cff68fd58c8d18 (diff)
downloadaur-a2fd23de4a3d8a4da44f2d5d1ed9c8143edebe14.tar.gz
Update to 42.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 803da2fa70f6..6a9e2262ddd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=41.1
+pkgver=42.0
pkgrel=1
pkgdesc='Phone dialer and call handler'
arch=(x86_64 aarch64)
@@ -18,16 +18,30 @@ depends=(
sofia-sip
)
makedepends=(
+ git
gobject-introspection
meson
vala
)
+options=(debug)
_commit=${pkgver}
-source=("${url}/-/archive/${_commit}/calls-${_commit}.tar.gz")
-sha256sums=('8b9a217f9f33fea314b33ee373d893177595faa97b38248769b50b07c238ab3f')
+source=(
+ "git+${url}.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/World/Phosh/libcall-ui.git"
+)
+b2sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd calls
+
+ git submodule init
+ git submodule set-url subprojects/libcall-ui "$srcdir/libcall-ui"
+ git submodule update
+}
+
build() {
- arch-meson calls-${_commit} build -D tests=false
+ arch-meson calls build -D tests=false
meson compile -C build
}