summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2019-02-06 18:44:56 +0100
committerPhilip Goto2019-02-06 18:44:56 +0100
commitd70c08c1eb4e9ecf9ac339731c5c1a0870aa784a (patch)
tree65966e07c6b882b96bc8b220787b21f2639f19cd /PKGBUILD
downloadaur-d70c08c1eb4e9ecf9ac339731c5c1a0870aa784a.tar.gz
Initialize package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb225c5bd12d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=calls
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A phone dialer and call handler."
+arch=(i686 x86_64 armv6h armv7h)
+url="https://source.puri.sm/Librem5/calls"
+license=(GPL3)
+depends=(gsound
+ libhandy
+ libpeas
+ modemmanager)
+makedepends=()
+source=("https://source.puri.sm/Librem5/calls/-/archive/v${pkgver}/calls-v${pkgver}.tar.gz")
+sha256sums=(SKIP)
+
+build() {
+ rm -rf build
+ arch-meson calls-v${pkgver} build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+}