summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2020-01-03 19:38:22 +0100
committerPhilip Goto2020-01-03 19:38:22 +0100
commitfad7d548fd0cb2392b66c60c07d6ff2bfa785880 (patch)
tree134f5625b01490233d0f00d4628defe254da1950 /PKGBUILD
parent5500e4ea474a3fdf895754859ab7b457a6c72bb0 (diff)
downloadaur-fad7d548fd0cb2392b66c60c07d6ff2bfa785880.tar.gz
Update to 0.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7499c7ff8cad..a7a9a45f75ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=0.0.1
+pkgver=0.1.1
pkgrel=1
pkgdesc="Phone dialer and call handler"
arch=(i686 x86_64 armv6h armv7h)
url="https://source.puri.sm/Librem5/calls"
license=(GPL3)
-depends=(gsound
+depends=(folks
+ gom
+ gsound
libhandy
libpeas
modemmanager)
-makedepends=(gobject-introspection)
+makedepends=(gobject-introspection
+ meson
+ vala)
source=("https://source.puri.sm/Librem5/calls/-/archive/v${pkgver}/calls-v${pkgver}.tar.gz")
-sha256sums=(SKIP)
+sha256sums=('f0f574e92368664a4dd9dff9521dfa7245b736206d9f95a0c00f5786a862c9cf')
build() {
- rm -rf build
arch-meson calls-v${pkgver} build
ninja -C build
}
-check() {
- ninja -C build test
-}
+# check() {
+# ninja -C build test
+# }
package() {
DESTDIR="$pkgdir/" ninja -C build install