summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-03-24 17:04:55 +0800
committerzxp198210052023-03-24 17:04:55 +0800
commit59a84148fc30feaef8ae399a7ce8a1a862ae9c27 (patch)
tree83db9b63406dd8ffba73e4c56753240430311351 /PKGBUILD
parent4e92a833514f622358a6cc749507d415801473e1 (diff)
downloadaur-59a84148fc30feaef8ae399a7ce8a1a862ae9c27.tar.gz
fix denpendt error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b03be0ff26a..b86d0fe0212b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname=calmly-writer-bin
_pkgname=calmly-writer
+pkgname="${_pkgname}-bin"
pkgver=2.0.52
-pkgrel=1
+pkgrel=2
pkgdesc="Calmly Writer is an editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface."
arch=('x86_64')
url="https://www.calmlywriter.com"
-license=('unknown')
-conflicts=('calmly-writer')
-depends=()
+license=('custom')
+conflicts=("${_pkgname}")
+depends=(gtk3 glibc libxrandr libxfixes libxkbcommon lib32-gcc-libs pango libdrm libcups gdk-pixbuf2 alsa-lib at-spi2-core libx11 libxdamage \
+ nspr libxcb nss dbus hicolor-icon-theme libxext libxcomposite mesa gcc-libs glib2 lib32-glibc expat cairo sh)
options=()
-source=("${_pkgname}_${pkgver}.deb::${url}/releases/linux/deb/x64/${_pkgname}_${pkgver}_amd64.deb")
-sha512sums=('38c9564575899ab334ca25f0e9e8d3b8d9ef392eaf7e04150ea281c49652817c10c37b236f82bec6cd9b902baeb1d3e371901d9ebbbfbf82d720e89e934b3b58')
+source=("${_pkgname}_${pkgver}.deb::${url}/releases/linux/deb/x64/${_pkgname}_${pkgver}_amd64.deb"
+ "LICENSE::${url}/eula.htm")
+sha256sums=('45d223301278c81479e5483372805ce409c53c4c1412975312990ee39e6c031a'
+ '57ca9932cc353e0734325a3e0377abc9645021c908a81a44446b2153ee19c6d9')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
-}
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file