summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-08-02 17:19:07 +0800
committerzxp198210052023-08-02 17:19:07 +0800
commit74e541ecdf7eeceacd8cca88f469f5fa37e8cad3 (patch)
tree7a0b0c0883cd1432f6f16ea4662ac6b22f2837dd /PKGBUILD
parent976504cfc758f4700d3cc60fe7c96bdbb33d9d43 (diff)
downloadaur-74e541ecdf7eeceacd8cca88f469f5fa37e8cad3.tar.gz
update to 2.0.54
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2096d540b86d..68aab7af22ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="calmly-writer-bin"
-pkgver=2.0.52
-pkgrel=3
+pkgver=2.0.54
+pkgrel=1
pkgdesc="Calmly Writer is an editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface."
-arch=('x86_64')
+arch=('aarch64' 'x86_64')
url="https://www.calmlywriter.com"
license=('custom')
conflicts=("${pkgname%-bin}")
@@ -12,10 +12,12 @@ depends=('gtk3' 'glibc' 'libxrandr' 'libxfixes' 'libxkbcommon' 'lib32-gcc-libs'
'nspr' 'libxcb' 'nss' 'dbus' 'hicolor-icon-theme' 'libxext' 'libxcomposite' 'mesa' \
'gcc-libs' 'glib2' 'lib32-glibc' 'expat' 'cairo' 'sh')
options=()
-source=("${pkgname%-bin}_${pkgver}.deb::${url}/releases/linux/deb/x64/${pkgname%-bin}_${pkgver}_amd64.deb"
- "LICENSE.html::${url}/eula.htm")
-sha256sums=('45d223301278c81479e5483372805ce409c53c4c1412975312990ee39e6c031a'
- '57ca9932cc353e0734325a3e0377abc9645021c908a81a44446b2153ee19c6d9')
+source_aarch64=("${pkgname%-bin}_${pkgver}-aarch64.deb::${url}/releases/linux/deb/arm64/${pkgname%-bin}_${pkgver}_arm64.deb")
+source_x86_64=("${pkgname%-bin}_${pkgver}-x86_64.deb::${url}/releases/linux/deb/x64/${pkgname%-bin}_${pkgver}_amd64.deb")
+source=("LICENSE.html::${url}/eula.htm")
+sha256sums=('79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb')
+sha256sums_aarch64=('dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e')
+sha256sums_x86_64=('91432bec316b83ef3a0e47815c4db9ec38903704e19c61e29f32782f327a3897')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"