summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-02-28 15:33:38 +0800
committerzxp198210052024-02-28 15:33:38 +0800
commit7eb7c7430bc6740fa39e861cd1a8052246656496 (patch)
treed849ff5ab454df838d9c2076d3c77fecb4d6da56 /PKGBUILD
parent0b2a22711350aafb5924796e1d4478f7226049cf (diff)
downloadaur-7eb7c7430bc6740fa39e861cd1a8052246656496.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8293dda2552..a3ef7e0f9119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=calmly-writer-bin
_pkgname="Calmly Writer"
pkgver=2.0.54
-_electronversion=24
-pkgrel=5
+_electronversion=17
+pkgrel=6
pkgdesc="An editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface."
arch=(
'aarch64'
@@ -17,8 +17,6 @@ options=('!strip')
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'lib32-glibc'
- 'lib32-gcc-libs'
)
source_aarch64=("${pkgname%-bin}_${pkgver}-aarch64.deb::${url}/releases/linux/deb/arm64/${pkgname%-bin}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}_${pkgver}-x86_64.deb::${url}/releases/linux/deb/x64/${pkgname%-bin}_${pkgver}_amd64.deb")
@@ -27,15 +25,15 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e')
sha256sums_x86_64=('91432bec316b83ef3a0e47815c4db9ec38903704e19c61e29f32782f327a3897')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {