summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-09-09 09:36:36 +0800
committerzxp198210052023-09-09 09:36:36 +0800
commit8b9722fe5e4c81e86d605012f88b887ffdf0065b (patch)
treef61e57e70234cf1e3d074044950d0b43d60a23bf /PKGBUILD
parent8bc73770eb9d9b3c57985fcb2435c86ec8954e0a (diff)
downloadaur-8b9722fe5e4c81e86d605012f88b887ffdf0065b.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2312b1969d0..6b890c91b95b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,38 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="calmly-writer-bin"
+pkgname=calmly-writer-bin
+_pkgname="Calmly Writer"
pkgver=2.0.54
-pkgrel=2
+pkgrel=3
pkgdesc="Calmly Writer is an editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface."
arch=('aarch64' 'x86_64')
url="https://www.calmlywriter.com"
license=('custom')
conflicts=("${pkgname%-bin}")
-depends=('gtk3' 'glibc' 'libxrandr' 'libxfixes' 'libxkbcommon' 'lib32-gcc-libs' 'pango' \
- 'libdrm' 'libcups' 'gdk-pixbuf2' 'alsa-lib' 'at-spi2-core' 'libx11' 'libxdamage' \
- 'nspr' 'libxcb' 'nss' 'dbus' 'hicolor-icon-theme' 'libxext' 'libxcomposite' 'mesa' \
- 'gcc-libs' 'glib2' 'lib32-glibc' 'expat' 'cairo' 'sh')
+provides=("${pkgname%-bin}=${pkgver}")
+depends=('bash' 'electron24' 'hicolor-icon-theme')
+makedepends=('asar')
source_aarch64=("${pkgname%-bin}_${pkgver}-aarch64.deb::${url}/releases/linux/deb/arm64/${pkgname%-bin}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}_${pkgver}-x86_64.deb::${url}/releases/linux/deb/x64/${pkgname%-bin}_${pkgver}_amd64.deb")
-source=("LICENSE.html::${url}/eula.htm")
-sha256sums=('79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb')
+source=("LICENSE.html::${url}/eula.htm"
+ "${pkgname%-bin}.sh")
+sha256sums=('79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb'
+ 'df7583360a6f6607332c59670fc00f758f6bfc5ec2167b36e556f67e6446bd10')
sha256sums_aarch64=('dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e')
sha256sums_x86_64=('91432bec316b83ef3a0e47815c4db9ec38903704e19c61e29f32782f327a3897')
+prepare() {
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ asar e "${srcdir}/opt/${_pkgname}/resources/app.asar" "${srcdir}/app.asar.unpacked"
+ cp -r "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked" "${srcdir}"
+ asar p "${srcdir}/app.asar.unpacked" "${srcdir}/${pkgname%-bin}.asar"
+ sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
package() {
- bsdtar -xf data.tar.xz -C "${pkgdir}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
+ for _icons in 16x16 32x32 64x64 128x128 256x256 512x512;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file