summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhotonQuantum2019-08-28 20:27:14 +0800
committerPhotonQuantum2019-08-28 20:27:14 +0800
commit8a202ca3b5b36714339463eb1eb714c0236728b4 (patch)
tree88aff4cf7fa16d7a677ab72a3bf54f89949f5380 /PKGBUILD
parent324968e8cc86d2ff72cb968f246804a7f7d102c5 (diff)
downloadaur-8a202ca3b5b36714339463eb1eb714c0236728b4.tar.gz
update binary & config path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1173bdbca156..d3a6d9d544c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: LightQuantum <cy.n01@outlook.com>
pkgname=calorina-git
_pkgname=calorina
-pkgver=3.2.1.r0.g8978847
+pkgver=4.1.0.r0.g6843422
pkgrel=1
pkgdesc='Project Calorina - a complete rewrite of cleardns'
arch=('x86_64')
@@ -12,7 +12,7 @@ backup=("etc/$_pkgname/config.toml")
source=("git+https://gitlab.com/NickCao/$_pkgname"
calorina.service)
md5sums=('SKIP'
- '2e9c6347d4876f4ac42243a01af8dfad')
+ '14dc2936e63fe910017e18ab006747a2')
pkgver() {
cd $_pkgname
@@ -21,18 +21,17 @@ pkgver() {
build() {
cd $_pkgname
- go build \
+ CGO_ENABLED=0 go build \
-gcflags "all=-trimpath=$PWD" \
-asmflags "all=-trimpath=$PWD" \
-ldflags "-extldflags $LDFLAGS" \
- -o $_pkgname cmd/$_pkgname-dns-demo/main.go
+ -o $_pkgname cmd/${_pkgname}d/main.go
}
package() {
cd "${srcdir}/"
- install -Dm755 $_pkgname/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm755 $_pkgname/$_pkgname "$pkgdir"/usr/bin/${_pkgname}d
install -Dm644 $_pkgname.service "$pkgdir"/usr/lib/systemd/system/$_pkgname.service
- install -Dm644 $_pkgname@.service "$pkgdir"/usr/lib/systemd/system/$_pkgname@.service
- install -Dm644 $_pkgname/cmd/$_pkgname-dns-demo/config.toml "$pkgdir"/etc/$_pkgname/config.toml
+ install -Dm644 $_pkgname/share/config.toml "$pkgdir"/etc/$_pkgname/config.toml
}