summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorderwinlu2019-05-05 07:09:23 +0200
committerderwinlu2019-05-05 07:09:23 +0200
commitd3e6b84cd824367400ccd0be3a871744a36db3da (patch)
tree80f0640dfcca9c69c99127e4bab6d4b7a9790d13 /PKGBUILD
downloadaur-d3e6b84cd824367400ccd0be3a871744a36db3da.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64c6ee63a156
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: winlu <derwinlu@gmail.com>
+
+pkgname=camel-k-bin
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="Apache Camel K (a.k.a. Kamel) is a lightweight integration framework built from Apache Camel that runs natively on Kubernetes and is specifically designed for serverless and microservice architectures."
+url="https://github.com/apache/camel-k"
+license=('Apache 2.0')
+arch=('x86_64')
+
+source_x86_64=("https://github.com/apache/camel-k/releases/download/${pkgver}/camel-k-client-${pkgver}-linux-64bit.tar.gz")
+sha256sums_x86_64=('7137a12c206be640268f564ff834fd1ffecace461954ae88cf357b420f52ebce')
+
+
+package() {
+ install -Dm755 "$srcdir/kamel" "$pkgdir/usr/bin/kamel"
+}