diff options
author | rern | 2023-08-09 11:36:09 +0700 |
---|---|---|
committer | rern | 2023-08-09 11:36:09 +0700 |
commit | 8faea703ed4e7cebe8d5811986d09cc58cc04520 (patch) | |
tree | e2318529225253be74c7cc5337007c23ffbc8edc /PKGBUILD | |
parent | 7bf9453ffd68e28c1dd49f1587c672372351e252 (diff) | |
download | aur-8faea703ed4e7cebe8d5811986d09cc58cc04520.tar.gz |
Revise script
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x | PKGBUILD | 25 |
1 files changed, 13 insertions, 12 deletions
@@ -9,21 +9,22 @@ arch=(armv7h aarch64) license=(GPL) depends=(alsa-lib openssl) makedepends=(pkg-config) -sourcefile=camilladsp-linux-$( sed -n -E '/^CARCH/ {s/.*="|h*"//g; p}' /etc/makepkg.conf ).tar.gz -source=($url/releases/download/v$pkgver/$sourcefile +source=(camilladsp.default camilladsp.service camilladsp.yml) -sha256sums=('SKIP') - -build() { - install -d $srcdir/bin - bsdtar xf $sourcefile -C $srcdir/bin -} +source_armv7h=($url/releases/download/v$pkgver/camilladsp-linux-armv7.tar.gz) +source_aarch64=(${source_armv7h/armv7/aarch64}) +sha256sums=('245d0ba135c81590ea5d8a1eb68741daf055192869128cad26242924dbcd5144' + '2ddfad846b2a6e57a27302849c03e47e5ce062b3365cb67d8525c80963bef689' + 'e1cf14d2bc164b201c6f6ab162ea69d5f73db257b6923b9ab0ea7eddccb2e1be') +sha256sums_armv7h=('0fa240fa9d96b9c57715616452fefc0ab6f5a091af2ae94449aa346d41ec90a4') +sha256sums_aarch64=('dab6f94363c97ad2569c458e53b04efdc571f2e7bbf94671378513a61ec1d9f3') package() { - install -Dm 775 $srcdir/bin/camilladsp -t $pkgdir/usr/bin - install -d $pkgdir/srv/http/data/camilladsp/coeffs - install -Dm 755 camilladsp.yml -t $pkgdir/srv/http/data/camilladsp/configs + cd $srcdir + install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname + install -d $pkgdir/etc/camilladsp/coeffs + install -Dm 755 camilladsp.yml -t $pkgdir/etc/camilladsp/configs install -Dm 644 camilladsp.service -t $pkgdir/usr/lib/systemd/system - install -Dm 644 camilladsp -t $pkgdir/etc/default + install -Dm 644 camilladsp.default $pkgdir/etc/default/camilladsp } |