summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrern2022-04-17 08:18:30 +0000
committerrern2022-04-17 08:18:30 +0000
commit1aed0b5dcd4d219bb8bc64e6277f90d1dac13277 (patch)
tree228bfc957b6b384d9db5f3e3f4580e81bf657b75 /PKGBUILD
parent784bcf0c3924935710ec8660542069f07d3bfc98 (diff)
downloadaur-1aed0b5dcd4d219bb8bc64e6277f90d1dac13277.tar.gz
Add *.service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f47355260923..0e32a7320ab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ license=(GPL)
depends=(camilladsp python-aiohttp python-pycamilladsp python-pycamilladsp-plot)
makedepends=(unzip)
install=camillagui.install
-source=(https://github.com/HEnquist/camillagui-backend/releases/download/v$pkgver/camillagui.zip)
-sha256sums=(6c70a8950a9dc3c8752efa77d60ec863035913d7775411034dd21c8b9a603bf3)
+source=(https://github.com/HEnquist/camillagui-backend/releases/download/v$pkgver/camillagui.zip
+ camillagui.service)
+sha256sums=(6c70a8950a9dc3c8752efa77d60ec863035913d7775411034dd21c8b9a603bf3
+ 816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240)
build() {
installdir=$srcdir/srv/http/settings/camillagui
@@ -24,4 +26,5 @@ build() {
package() {
mv $srcdir/srv $pkgdir
install -d $pkgdir/$installdir
+ install -Dm 644 camillagui.service -t $pkgdir/usr/lib/systemd/system
}