summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Legner2016-10-27 14:08:54 +0200
committerSimon Legner2016-10-27 14:09:17 +0200
commit3b383c56e2d06227365393d738d059b2fd6411d9 (patch)
treee34bfec43dc3e20d7912ff077561c7bde4b22020 /PKGBUILD
parente23565c983c21f60787b6ba027c08ff81564246a (diff)
parent8fae360cd75a0ab18f40b241e1abb4a8d637fe97 (diff)
downloadaur-3b383c56e2d06227365393d738d059b2fd6411d9.tar.gz
Merge branch 'ocaml-4.03', update to 1.05-6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 192f4e849eb4..24bff7e0f593 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
# Contributor: Jakob Nixdorf <flocke@shadowice.org>
+# Contributor: Bertram Felgenhauer <int-e@gmx.de>
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=camlidl
pkgver=1.05
-pkgrel=5
+pkgrel=6
pkgdesc="A stub code generator and COM binding for Objective Caml (OCaml)"
arch=('i686' 'x86_64')
url="http://caml.inria.fr/pub/old_caml_site/camlidl/"
@@ -12,24 +13,27 @@ depends=('ocaml')
options=(staticlibs)
source=(http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/$pkgname-$pkgver.tar.gz
arch-build-system-fix.patch
+ rename-array-module-for-ocaml-4.03.patch
META.camlidl)
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
-
patch -Np1 -i ${srcdir}/arch-build-system-fix.patch
-
+ patch -Np1 -i ${srcdir}/rename-array-module-for-ocaml-4.03.patch
cp config/Makefile.unix config/Makefile
+}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
make all
}
package() {
cd "$srcdir/$pkgname-$pkgver"
-
+
local _ocamldir=$(ocamlc -where)
mkdir -p ${pkgdir}/usr/bin ${pkgdir}/${_ocamldir}/{caml,${pkgname}}
-
+
make DESTDIR=${pkgdir} install
install -Dm644 ${srcdir}/META.camlidl ${pkgdir}/${_ocamldir}/${pkgname}/META
@@ -37,8 +41,10 @@ package() {
}
md5sums=('4cfb863bc3cbdc1af2502042c45cc675'
- '050c117fbddf73e7f7ca64cf1c17c644'
+ '9b7f92ec77b50d260b6487e4577bd5f0'
+ '937930d2b49a6df80567464350cb3fd9'
'c8239780b7303f02b86ca6efc644640c')
sha1sums=('2a0d5ba70fea8c1de1c5387f8b2058357b2177df'
- 'a7869f04e83a279ad8327f7cade60b1e470cd24a'
+ 'b5cf6873bda3fe48f9946f09ccea39cd60fda59c'
+ '19e42c60e2e7448951fc87bb70a3e8fb26244e08'
'cdabd68036a1f52c8ba8cfb22bde5a034ff8b620')