summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Legner2016-10-27 14:04:33 +0200
committerSimon Legner2016-10-27 14:04:33 +0200
commit8fae360cd75a0ab18f40b241e1abb4a8d637fe97 (patch)
tree44d1fc2440a19dcc3890f39b2e5bc93799eb03a9 /PKGBUILD
parent0fcd360b6f5ea9f629d3df4941755debec77144a (diff)
downloadaur-8fae360cd75a0ab18f40b241e1abb4a8d637fe97.tar.gz
Also rename array module in compiler/.depend
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f2651e061bb..24bff7e0f593 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
# Contributor: Jakob Nixdorf <flocke@shadowice.org>
+# Contributor: Bertram Felgenhauer <int-e@gmx.de>
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=camlidl
pkgver=1.05
@@ -15,23 +16,24 @@ source=(http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/$pkgname-$pkg
rename-array-module-for-ocaml-4.03.patch
META.camlidl)
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
-
patch -Np1 -i ${srcdir}/arch-build-system-fix.patch
patch -Np1 -i ${srcdir}/rename-array-module-for-ocaml-4.03.patch
-
cp config/Makefile.unix config/Makefile
+}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
make all
}
package() {
cd "$srcdir/$pkgname-$pkgver"
-
+
local _ocamldir=$(ocamlc -where)
mkdir -p ${pkgdir}/usr/bin ${pkgdir}/${_ocamldir}/{caml,${pkgname}}
-
+
make DESTDIR=${pkgdir} install
install -Dm644 ${srcdir}/META.camlidl ${pkgdir}/${_ocamldir}/${pkgname}/META
@@ -40,9 +42,9 @@ package() {
md5sums=('4cfb863bc3cbdc1af2502042c45cc675'
'9b7f92ec77b50d260b6487e4577bd5f0'
- '162464cc1dfaf47019cbe2cef29bcab4'
+ '937930d2b49a6df80567464350cb3fd9'
'c8239780b7303f02b86ca6efc644640c')
sha1sums=('2a0d5ba70fea8c1de1c5387f8b2058357b2177df'
'b5cf6873bda3fe48f9946f09ccea39cd60fda59c'
- '7665ee975581904ce605b1c006baa92189d7f3de'
+ '19e42c60e2e7448951fc87bb70a3e8fb26244e08'
'cdabd68036a1f52c8ba8cfb22bde5a034ff8b620')