summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin R. St-Amant2017-01-07 12:46:26 -0600
committerJustin R. St-Amant2017-01-07 12:46:26 -0600
commitd0f9462953c4605c2e626f7f26ad292b4b9279b7 (patch)
tree1e01828c8119ebe3a6ea796b0e01c11a3579bd2d /PKGBUILD
parentb5bb32e0c6fae91a63d86aa90c9ad5c22038bf88 (diff)
downloadaur-d0f9462953c4605c2e626f7f26ad292b4b9279b7.tar.gz
Improved deps and added a desktop entry
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2fbadca6dcb..588523f92e4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Justin R. St-Amant <jstamant24 at gmail dot com>
pkgname=camotics-git
-pkgver=1.0.6.r15.ga799aa8
+pkgver=1.0.6.r127.g776b29b
pkgrel=1
pkgdesc="3-axis NC machining simulation software"
arch=('i686' 'x86_64')
@@ -15,16 +15,17 @@ depends=('boost-libs'
'libgl'
'libmariadbclient'
'openssl'
- 'qt5-base'
+ 'qt4'
'sqlite'
- 'v8-3.14'
+ 'v8'
'zlib')
makedepends=('boost' 'scons')
provides=('camotics')
replaces=('openscam')
source=("$pkgname::git+https://github.com/CauldronDevelopmentLLC/CAMotics.git"
- "git+https://github.com/CauldronDevelopmentLLC/cbang.git")
-md5sums=('SKIP' 'SKIP')
+ "git+https://github.com/CauldronDevelopmentLLC/cbang.git"
+ "camotics.desktop")
+md5sums=('SKIP' 'SKIP' 'bca9df64570c6c6e6773e8428e27cfb8')
pkgver() {
cd "$srcdir/$pkgname"
@@ -41,6 +42,10 @@ build() {
}
package() {
+ cd "$srcdir"
+ install -Dm644 "camotics.desktop" \
+ "$pkgdir/usr/share/applications/camotics.desktop"
cd "$srcdir/$pkgname"
+ install -Dm644 "images/camotics.png" "$pkgdir/usr/share/pixmaps/camotics.png"
scons install compiler=gnu install_prefix="$pkgdir/usr"
}