summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn W. Burton2022-07-12 16:24:06 -0400
committerTarn W. Burton2022-07-12 16:24:06 -0400
commitbdc77c9ffa27d2499c0cbad8827dd3220e7a7349 (patch)
tree3a2058712551353814ed6000769aa44cc7b5b7f5 /PKGBUILD
parentdee5f2926f1a951a43d2074b277969255f792191 (diff)
downloadaur-bdc77c9ffa27d2499c0cbad8827dd3220e7a7349.tar.gz
Update for llvm14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e59ff40063b2..a1f58d73ffc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Tarn W. Burton <twburton@gmail.com>
pkgname=cando-git
-pkgver=1.0.0_326_ge114cb7a6_g4cc49c25
+pkgver=1.0.0_400_gdac6611de_g974275d5
pkgrel=1
pkgdesc="Bringing Common Lisp and C++ Together, including Cando"
arch=('x86_64')
url="https://github.com/clasp-developers/clasp"
license=('LGPL')
options+=(!strip)
-depends=('boost' 'expat' 'fmt' 'gmp' 'libbsd' 'libedit' 'clang13' 'zeromq'
- 'libelf' 'libffi' 'llvm13' 'netcdf' 'ninja' 'ncurses' 'zlib')
+depends=('boost' 'expat' 'fmt' 'gmp' 'libbsd' 'libedit' 'clang' 'zeromq'
+ 'libelf' 'libffi' 'llvm' 'netcdf' 'ninja' 'ncurses' 'zlib')
makedepends=('git' 'sbcl' 'pkg-config')
provides=('cclasp-boehm' 'common-lisp' 'clasp-cl' 'cando')
conflicts=('clasp-cl-git')
@@ -17,7 +17,7 @@ sha512sums=('SKIP')
prepare() {
cd clasp
- ./koga --reproducible-build --llvm-config=/usr/lib/llvm13/bin/llvm-config --package-path=$pkgdir --extensions=cando,seqan-clasp --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
+ ./koga --reproducible-build --broken-stdlib --package-path=$pkgdir --extensions=cando,seqan-clasp --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
./koga --skip-sync --extensions=cando,seqan-clasp --update-version
}