summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn W. Burton2022-07-03 09:47:33 -0400
committerTarn W. Burton2022-07-03 09:47:33 -0400
commitce382943021a3d0d409260f55f680dea2aaf2934 (patch)
treea26b7ac387212d0aa8ba611291348416b57ad3b9 /PKGBUILD
parentf270ba690ba0f8bdc87eb1c530b1293e249f6118 (diff)
downloadaur-ce382943021a3d0d409260f55f680dea2aaf2934.tar.gz
Update for llvm13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3ae403f4fec..398ddc687904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Tarn W. Burton <twburton@gmail.com>
pkgname=cando-git
-pkgver=1.0.0_276_g108eb3dd9_g06ea9a4f
+pkgver=1.0.0_317_gfe74d9b5b_g9e28f650
pkgrel=1
pkgdesc="Bringing Common Lisp and C++ Together, including Cando"
arch=('x86_64')
url="https://github.com/clasp-developers/clasp"
license=('LGPL')
options+=(!strip)
-depends=('boost' 'expat' 'fmt' 'gmp' 'libbsd' 'libedit' 'clang' 'zeromq'
- 'libelf' 'libffi' 'llvm' 'netcdf' 'ncurses' 'zlib')
+depends=('boost' 'expat' 'fmt' 'gmp' 'libbsd' 'libedit' 'clang13' 'zeromq'
+ 'libelf' 'libffi' 'llvm13' 'netcdf' 'ncurses' 'zlib')
makedepends=('git' 'sbcl' 'ninja' 'pkg-config')
provides=('cclasp-boehm' 'common-lisp' 'clasp-cl' 'cando')
conflicts=('clasp-cl-git')
@@ -17,7 +17,7 @@ sha512sums=('SKIP')
prepare() {
cd clasp
- ./koga --package-path=$pkgdir --extensions=cando,seqan-clasp --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
+ ./koga --llvm-config=/usr/lib/llvm13/bin/llvm-config --package-path=$pkgdir --extensions=cando,seqan-clasp --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
./koga --skip-sync --extensions=cando,seqan-clasp --update-version
}