summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroshaboy2019-12-11 18:29:08 +0200
committeroshaboy2019-12-11 18:29:08 +0200
commit7b6ffcef8d0357d05d8b00b7587a96e1973c6a64 (patch)
tree0e8710159bfac73227937188c9eeb583ce09fb10 /PKGBUILD
downloadaur-7b6ffcef8d0357d05d8b00b7587a96e1973c6a64.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d76e4b3bbe3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: oshaboy <noamgilor{at}protonmail{dot}com>
+
+pkgname=candybox2
+pkgver=1
+pkgrel=1
+pkgdesc="Text Based Incremental Game"
+arch=('any')
+url="https://github.com/candybox2"
+license=('GPL')
+depends=(chromium)
+optdepends=()
+makedepends=(git)
+source=("git+https://github.com/candybox2/candybox2.github.io.git")
+sha256sums=('SKIP')
+
+build(){
+ echo -e '#!/bin/sh\nchromium -app="file:///opt/candybox2/index.html"' >| ${srcdir}/candybox2.sh
+}
+
+package(){
+ mkdir "${pkgdir}/opt"
+ cp -r "${srcdir}/candybox2" "${pkgdir}/opt/candybox2"
+ find ${pkgdir}/opt/candybox2 -type d | xargs chmod 755
+ install -Dm755 ${srcdir}/candybox2.sh ${pkgdir}/usr/bin/candybox2
+}