summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuck Melanoma2021-11-23 11:30:50 -0800
committerBuck Melanoma2021-11-23 11:30:50 -0800
commitefc93827fda596e8ff854308cc77002d0273bdb5 (patch)
treee2f87539dd1dc2a7b568a5dfc84d0a6da8bc6513 /PKGBUILD
parent8cb48ac0a4e77ff6e723d041dd43716cb7f5ae47 (diff)
downloadaur-efc93827fda596e8ff854308cc77002d0273bdb5.tar.gz
Formatting tweaks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eda1b0a7b697..4921cfa3021d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,27 +15,26 @@ source=($pkgname-$pkgver.tar.gz::"https://github.com/djyt/cannonball/archive/v$p
"$pkgname.sh")
sha256sums=('e2cf8e21619b183a9fd835ae34ce65fb3d014c2fea37723fc8ba05681ed317ce'
'04d0c0e9252bccfef97bb59c9e89376461f9b52845570b2ebc14610ce74cf1ff'
- '582b6dd0ec05ba132ac0084002d6181ce80c7bc550ed57057d884e312009c196')
+ '787fdfef544e41f5c358afb1a8d31bf22d0ff48631467b590f046dbcd9fc45af')
prepare() {
cd $pkgname-$pkgver
-
rm -rf build
mkdir build
}
build() {
cd $pkgname-$pkgver/build
-
- cmake ../cmake -Wno-dev -DTARGET=linux.cmake -DOpenGL_GL_PREFERENCE=GLVND -B .
+ cmake ../cmake -DTARGET=linux.cmake -DOpenGL_GL_PREFERENCE=GLVND -B .
make
}
package() {
cd $pkgname-$pkgver
- # xdg desktop, launcher, binary
+ # xdg desktop, icon, launcher, binary
install -Dm755 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 res/icon.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/$pkgname.png
install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
install -Dm755 build/$pkgname "$pkgdir"/usr/lib/$pkgname/$pkgname
@@ -45,7 +44,4 @@ package() {
# doc + license
install -Dm644 roms/roms.txt "$pkgdir"/usr/share/doc/$pkgname/roms.txt
install -Dm644 docs/license.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt
-
- # icon
- install -Dm644 res/icon.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/$pkgname.png
}