summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClemmitt Sigler2022-11-10 07:47:19 -0500
committerClemmitt Sigler2022-11-10 07:47:19 -0500
commitb64eed2eec18007b766db1df8b92ca9062564a4a (patch)
tree3f9937076962bfca9f3ba167f2b7b2e9ea1221bc /PKGBUILD
parent38a3157aeed2f51339a6b1c880ba1f89f926ed47 (diff)
downloadaur-canorus-git.tar.gz
Removing python support which causes segfault on start-up
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1db19c5d282..02f27c7aef6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,8 +26,9 @@ build() {
cd "$srcdir/${pkgname%-git}"
# stringop-truncation will be fixes in swig, see https://github.com/swig/swig/issues/893
export CXXFLAGS+=" -Wno-misleading-indentation -Wno-dangling-else -Wno-stringop-truncation -Wno-deprecated -Wno-deprecated-declarations"
+# See https://github.com/canorusmusic/canorus/issues/182
cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
- -DDEFAULT_DATA_DIR="/usr/share/canorus"
+ -DDEFAULT_DATA_DIR="/usr/share/canorus" -DNO_PYTHON=1
make
}