summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRuben Di Battista2024-11-02 01:32:13 +0000
committerRuben Di Battista2024-11-02 01:34:23 +0000
commit86488025c3e0585bc2fd820a3ed6ed17f798abda (patch)
treee8f846f033950dbed5baf3c0b3fa2e0f2d26aa03 /PKGBUILD
parent0dc33174c0c18fa4a0e2b260499bfbbad91a8fd7 (diff)
downloadaur-cantera-git.tar.gz
Update cantera version to 3.x
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4d96ca326d1..c0525fd27f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Ruben Di Battista <rubendibattista at gmail dot com>
_pkgname=cantera
pkgname="${_pkgname}-git"
-pkgver=2.5.1.r1074.g80e93621f
+pkgver=3.1.0a4.r137.gafa45f417
pkgrel=1
pkgdesc='suite of tools for kinetics, thermodynamics, and transport processes'
arch=('x86_64')
@@ -10,11 +10,10 @@ url='https://cantera.org/'
license=('custom:Cantera Developers'
'custom:Sandia Corporation Contract AC04-94AL85000'
'custom:California Institute of Technology')
-depends=('sundials' 'python-numpy' 'openmp' 'yaml-cpp' 'fmt')
-makedepends=('scons' 'git' 'gcc' 'doxygen' 'cython')
+depends=('sundials' 'python-numpy' 'openmp' 'yaml-cpp' 'fmt' 'boost-libs')
+makedepends=('scons' 'git' 'gcc' 'doxygen' 'cython' 'eigen' 'boost' 'python-pip' 'python-setuptools')
checkdepends=('gtest' 'gmock' 'python-ruamel-yaml' 'python-pytest')
provides=('libcantera_shared.so=2-64')
-install="$pkgname.install"
source=(git+https://github.com/Cantera/cantera.git)
md5sums=('SKIP')
_python_v=$(python -c 'import sys; print(str(sys.version_info[0])+"."+str(sys.version_info[1]))')
@@ -29,8 +28,9 @@ build() {
# build cantera
scons -j $(nproc) build \
prefix="$pkgdir/usr" \
+ debug='n' \
system_eigen='y' \
- system_sundials='y' \
+ system_sundials='n' \
sundials_include='/usr/include/sundials' \
googletest='system' \
extra_inc_dirs='/usr/include/eigen3'