summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Baust2020-04-16 17:43:37 +0200
committerTobias Baust2020-04-16 17:43:37 +0200
commita926f293b734303942ba6bcd2c16d1b0425fb455 (patch)
tree0d57ec48b77cd9aa14a29e120ae3e642a4f564d2 /PKGBUILD
parent2e8c566d273fe4bb474063446f6f9aad963eed01 (diff)
downloadaur-a926f293b734303942ba6bcd2c16d1b0425fb455.tar.gz
removed sphinx due to missing sphinxcontrib.matlabdomain; exclude python related tests if optdepends are missing; fixed typos; updated .install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1c7932ff71a..7e079ca04803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=cantera
pkgname="${_pkgname}-git"
pkgver='2.4.0.r689.g29437efc4'
-pkgrel=1
+pkgrel=2
pkgdesc='suite of tools for kinetics, thermodynamics, and transport processes'
arch=('x86_64')
url='https://cantera.org/'
@@ -14,9 +14,8 @@ makedepends=('scons' 'git' 'gcc' 'fmt')
checkdepends=('gtest' 'gmock')
optdepends=('python-numpy: numerical python support'
'cython: compiler for python interface'
- 'python-ruamel-yaml: for cython test cases in check()'
+ 'python-ruamel-yaml: cython support'
'doxygen: documentation'
- 'python-sphinx: documentation'
'tcsh: csh scripts')
provides=('libcantera_shared.so=2-64')
install="$pkgname.install"
@@ -39,20 +38,26 @@ build() {
googletest='system' \
extra_inc_dirs='/usr/include/eigen3'
# build documentation
- if [ $(pacman -Qi doxygen &> /dev/null) -eq "0" ]; then
+ $(pacman -Qi doxygen &> /dev/null)
+ if [ "$?" -eq "0" ]; then
scons doxygen
fi
- if [ $(pacman -Qi python-sphinx &> /dev/null) -eq "0" ]; then
- scons sphinx
- fi
# build cantera samples
scons samples
}
check() {
cd "$_pkgname"
- # run tests
- scons test
+ $(pacman -Qi python-numpy &> /dev/null) && \
+ $(pacman -Qi python-ruamel-yaml &> /dev/null) && \
+ $(pacman -Qi cython &> /dev/null)
+ if [ "$?" -ne "0" ]; then
+ # run tests without python
+ scons test-help | grep "test-" | sed '/python/d' | xargs scons
+ else
+ # run all tests
+ scons test
+ fi
}
package() {