summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2021-01-09 10:30:35 -0500
committerMario Finelli2021-01-09 10:30:35 -0500
commit631c6dbfb7667744e91879a183895d071e56a756 (patch)
tree429ef0feb73161f39507df00864172bf0647feb6 /PKGBUILD
parent2ae70353418ea6e3cbd7f1309a775dc11b59b7d6 (diff)
downloadaur-631c6dbfb7667744e91879a183895d071e56a756.tar.gz
Update to 3.15.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 884f0fb92927..9ac6ad7f15df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=capistrano
-pkgver=3.14.1
+pkgver=3.15.0
pkgrel=1
pkgdesc="A remote server automation and deployment tool written in Ruby"
arch=(any)
url="http://capistranorb.com"
license=(MIT)
depends=(ruby ruby-rake ruby-sshkit ruby-i18n ruby-airbrussh)
-makedepends=(ruby-rdoc rubygems)
+makedepends=(git ruby-rdoc rubygems)
options=(!emptydirs)
-source=(https://github.com/capistrano/capistrano/archive/v${pkgver}.tar.gz)
-sha256sums=('501b8d5a227e8decfebcfbd4ff219cb30b3d04cba97d8177b707fd9e310be4ed')
+source=(git+https://github.com/capistrano/capistrano.git?tag=v${pkgver})
+sha256sums=('SKIP')
prepare() {
- cd ${pkgname}-${pkgver}
-
+ cd ${pkgname}
sed -i 's|~>|>=|g' ${pkgname}.gemspec
- sed -i 's|gem.files .*|gem.files = `find`.split("\\n")|' \
- ${pkgname}.gemspec
}
build() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}
gem build ${pkgname}.gemspec
}
package() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}
local _gemdir="$(gem env gemdir)"
gem install \