summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorl0gic2016-01-22 20:49:46 +0100
committerl0gic2016-01-22 20:49:46 +0100
commit9f9155e5dfbed5ef991202c7bf97097a62d007d1 (patch)
treeec93d4d9fce5693ce2ada0fcc03e0f0a79b16324 /PKGBUILD
parent274af505c2e5ff11ab8848584aab6cfe9404ba77 (diff)
downloadaur-9f9155e5dfbed5ef991202c7bf97097a62d007d1.tar.gz
Added workaround for linking error in make check
make check somehow expects libcapstone.so.4, whereas there is only a libcapstone.so present by the time the tests are run.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 389d35fc0418..0fc3275c2084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=capstone-git
-pkgver=20151229.2531.f9f0c80
+pkgver=20160122.2534.3722c74
pkgrel=1
pkgdesc="A lightweight multi-platform, multi-architecture disassembly framework."
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ optdepends=('python: for python3 bindings'
provides=('capstone')
conflicts=('capstone')
-source=("$pkgname"::"git://github.com/aquynh/capstone.git#branch=next")
+source=("${pkgname}::git+https://github.com/aquynh/capstone.git#branch=next")
md5sums=('SKIP')
pkgver () {
@@ -38,7 +38,7 @@ build() {
check() {
cd "${srcdir}/${pkgname}"
- make check
+ LD_PRELOAD="./tests/libcapstone.so" make check
# uncomment as needed
#cd "./bindings/python"