summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2017-04-06 13:00:55 -0400
committerTed Alff2017-04-06 13:00:55 -0400
commit222b13289f3415d3a68867d6f66d9e8dc88cae39 (patch)
treeb745fed09c76f8910474d7529191aa6bfde64556 /PKGBUILD
parent1a687bc3c1562c39415b2da541c2651d4b08c713 (diff)
downloadaur-cardapio-bzr.tar.gz
Updated (really uses git -- maybe I'll try to change the name)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 758f959cb48d..ddfeead3dc7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,37 @@
_pkgname=cardapio
pkgname=${_pkgname}-bzr
-pkgver=886
-pkgrel=2
+pkgver=996
+pkgrel=1
pkgdesc="An alternative Gnome menu, launcher, and much more!"
arch=('i686' 'x86_64')
url="https://launchpad.net/cardapio"
license=('GPL3')
conflicts=('cardapio')
provides=('cardapio')
-depends=('python2-xdg' 'xdg-user-dirs' 'python2-dbus' 'python2-gnomedesktop' 'python2-keybinder2' 'python2-simplejson' 'gnome-control-center' 'tk')
-makedepends=('bzr')
+depends=('python2-xdg' 'xdg-user-dirs' 'python2-dbus' 'gnome-python-desktop' 'python2-keybinder2')
+makedepends=('git')
optdepends=('tracker: search capability')
-source=('cardapio::bzr+https://launchpad.net/cardapio/trunk'
- 'arch_and_python_stuff.patch'
- 'xdg_fix.patch')
+source=('cardapio::git+https://git.launchpad.net/cardapio'
+ 'xdg_fix.patch'
+ 'xfce_cinnamon_better_support.patch')
pkgver() {
- cd "${_pkgname}"
- printf "%s" "$(bzr revno)"
+ cd ${srcdir}/${_pkgname}
+ git rev-list --count HEAD
}
prepare() {
- msg "Arch and Python2 adjustments..."
cd "${srcdir}/${_pkgname}"
- patch -uNp2 -r- -i ../arch_and_python_stuff.patch || return 1
- patch -uNp2 -r- -i ../xdg_fix.patch || return 1
+ # All the python2 fixes
+ sed -i 's:python\([ \t$]\):python2\1:g' Makefile
+ find ./src -type f -exec sed -i 's:\(#!.*python\):&2:' '{}' \;
+ # Doesn't like concatting NoneType + str
+ patch -uNp2 -r- -i ../xdg_fix.patch
+ # Add some cinnamon and xfce specifics
+ patch -uNp2 -r- -i ../xfce_cinnamon_better_support.patch
+ # We're not Ubuntu
+ rm src/plugins/software_center.py
}
build() {
@@ -39,9 +45,9 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
- rm "${pkgdir}"/usr/share/locale/cardapio.pot
+ rm "${pkgdir}"/usr/share/locale/cardapio.pot
}
sha256sums=('SKIP'
- '3fdaae9f4248c10d665492fb85f018d22d1a7120c65a1491efe58a2437bb98d0'
- '7c9915154d57c50724a5670b4dd4bb831f89208225690c3a0bcc039b60eefea3')
+ 'da05e1f24399ae3dc401ab3a89e05eb1a610c7777bbb45c723444f0c782fa5d9'
+ '8b3b22b9ee5e3d26b1f9c09f49b70f35f7a3ffb7e6579e87a7a78183482ec856')