summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlemust832015-08-10 04:52:36 +0200
committerlemust832015-08-10 04:52:36 +0200
commitcd2a38718e0abd6ffc040069afa897241e5f0d98 (patch)
treea0ff8f88842ab8275964f5b1bcfb5398fd43bf02 /PKGBUILD
downloadaur-cd2a38718e0abd6ffc040069afa897241e5f0d98.tar.gz
Origine
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b08408bdcf52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: lemust83 <lemust83420@gmail.com>
+# Contributor: Pierre-Olivier Vauboin <povauboin@gmail.com>
+
+pkgname=cardpeek
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="A tool to read the contents of smartcards"
+arch=(i686 x86_64)
+url="http://pannetrat.com/Cardpeek"
+license=('GPL')
+depends=('gtk3' 'lua52' 'pcsclite' 'curl')
+
+source=("http://downloads.pannetrat.com/install/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('9c78dfdf84493c551b49447e4bb46c8d7b33f0785b93893222b70b6115013a85')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure LUA_CFLAGS="-I/usr/include/lua5.2" LUA_LIBS="-llua5.2 -lm" --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file