summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgifnksm2022-09-13 18:58:35 +0900
committergifnksm2022-09-13 19:28:28 +0900
commit1633e63fc0e201e45b4cf4a52676a656e268685d (patch)
tree9ec8938c97285614a767f74611208231680bc067 /PKGBUILD
downloadaur-1633e63fc0e201e45b4cf4a52676a656e268685d.tar.gz
v0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdb379fc68b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: gifnksm <makoto.nksm+aur@gmail.com>
+pkgname=cargo-sync-rdme
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="Cargo subcommand to synchronize README with crate documentation"
+arch=('x86_64' 'aarch64')
+url="https://github.com/gifnksm/cargo-sync-rdme"
+license=('MIT' 'Apache')
+depends=('libgit2' 'cargo')
+conflicts=('cargo-sync-rdme-bin')
+provides=('cargo-sync-rdme')
+source=("${pkgname}-${pkgver}::https://github.com/gifnksm/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('09536b81604d562c94cb301d4927d7bb6239896906b2cd91fd867f6c19534820')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo xtask dist
+}
+
+test() {
+ cd "${pkgname}-${pkgver}"
+ cargo xtask test
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/target/xtask/dist/${pkgname}-v${pkgver}/"
+
+ install -Dm 755 "$(uname -m)-unknown-linux-gnu/cargo-sync-rdme" -t "${pkgdir}/usr/bin/"
+
+ install -Dm 644 noarch/man/cargo-sync-rdme.1 -t "${pkgdir}/usr/share/man/man1/"
+
+ install -Dm 644 noarch/completion/_cargo-sync-rdme -t "${pkgdir}/usr/share/zsh/site-functions/"
+ install -Dm 644 noarch/completion/cargo-sync-rdme.bash -t "${pkgdir}/usr/share/bash-completion/completions/"
+ install -Dm 644 noarch/completion/cargo-sync-rdme.fish -t "${pkgdir}/usr/share/fish/vendor_completions.d/"
+
+ install -Dm 644 noarch/LICENSE-* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 noarch/README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}