summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-01-05 14:50:52 -0800
committerLlewelyn Trahaearn2017-01-05 14:50:52 -0800
commit69d4cf1755d3e0774cd0f8c8d8952ae144e21d4c (patch)
treee427246d2df97d3c34b15b80e183f026efb452b2 /PKGBUILD
parente65bc8bd0ddff9c90d65570f0578a54f574b2b94 (diff)
downloadaur-69d4cf1755d3e0774cd0f8c8d8952ae144e21d4c.tar.gz
Update dependencies and make command per upstream recommentaitons.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0825aa309dc1..c95f5b2a6bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Audio Plugin Host"
arch=('i686' 'x86_64')
url="http://kxstudio.sf.net/carla"
license=('GPL2')
-depends=('file' 'fftw' 'fluidsynth' 'glu' 'liblo' 'linuxsampler-svn' 'mxml' 'ntk-git' 'projectm' 'python' 'zlib')
+depends=('file' 'fftw' 'fluidsynth' 'glu' 'liblo' 'linuxsampler' 'mxml' 'ntk-git' 'projectm' 'python' 'zlib')
makedepends=('gtk2' 'gtk3' 'pygtk' 'python-pyliblo' 'python-pyqt4' 'python-pyqt5' 'python-rdflib' 'qt4' 'qt5-base' 'zynaddsubfx')
optdepends=(
'gtk2: LV2 GTK2 UI support'
@@ -27,10 +27,10 @@ sha512sums=('f8b7247eace54a49398800a377efa9fb88267d52ccd0297a6fb4b64c04da24ac102
build() {
cd "${srcdir}/Carla-${pkgver}"
- make
+ make DEFAULT_QT=5
}
package() {
cd "${srcdir}/Carla-${pkgver}"
- make DESTDIR="${pkgdir}/" PREFIX=/usr install
+ make DEFAULT_QT=5 DESTDIR="${pkgdir}/" PREFIX=/usr install
}