summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-10-12 22:11:53 +0200
committerChristopher Arndt2022-10-12 22:11:53 +0200
commit9eb43ac21a3b67796b8c543111a77014433c4031 (patch)
treef814849296471550efc5377143fa21aa00ed148a /PKGBUILD
parenta618943e6f83fbe469243f9485b7a75b22f6fc01 (diff)
downloadaur-9eb43ac21a3b67796b8c543111a77014433c4031.tar.gz
Provides, groups and arch changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 37 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f1bf6b608cc..d9b5750dab3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,50 +2,58 @@
# Contributor: cocreature <moritz.kiefer<at>purelyfunctional<dot>org>
_name=Carla
-_pkgname="${_name,,}"
-pkgname="$_pkgname-git"
-pkgver=2.5.0.r1.ge3b25116d
+_pkgname=${_name,,}
+pkgname=$_pkgname-git
+pkgver=2.5.1.r47.gdf1338860
pkgrel=1
epoch=1
pkgdesc="Audio Plugin Host"
-arch=(i686 x86_64)
+arch=(x86_64)
url='https://kx.studio/Applications:Carla'
license=(GPL2)
-conflicts=("$_pkgname")
-provides=("$_pkgname" dssi-host ladspa-host lv2-host vst-host vst3-host)
+conflicts=($_pkgname)
+provides=(
+ $_pkgname
+ clap-host
+ dssi-host
+ ladspa-host
+ lv2-host
+ vst3-host
+ vst-host
+)
depends=(
- alsa-lib
- gcc-libs
- glibc
- hicolor-icon-theme
- libglvnd
- libx11
- python-pyqt5
- qt5-base
- qt5-svg
+ alsa-lib
+ gcc-libs
+ glibc
+ hicolor-icon-theme
+ libglvnd
+ libx11
+ python-pyqt5
+ qt5-base
+ qt5-svg
)
makedepends=(
- file
- fluidsynth
- freetype2
- git
- liblo
- libpulse
- libsndfile
- qt5-tools
+ file
+ fluidsynth
+ freetype2
+ git
+ liblo
+ libpulse
+ libsndfile
+ qt5-tools
)
optdepends=(
- 'jack: for using carla with JACK'
- 'lv2-host: for the LV2 plugin'
- 'vst-host: for the VST plugin'
- 'python-pyliblo: OSC control support'
- 'python-rdflib: LADSPA-RDF support'
+ 'jack: for using carla with JACK'
+ 'lv2-host: for the LV2 plugin'
+ 'vst-host: for the VST plugin'
+ 'python-pyliblo: OSC control support'
+ 'python-rdflib: LADSPA-RDF support'
)
+groups=(pro-audio lv2-plugins vst-plugins)
source=("$_pkgname::git+https://github.com/falkTX/$_name.git")
md5sums=('SKIP')
changelog='changelog.txt'
-
pkgver() {
cd $_pkgname
git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//"