summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosh Ellithorpe2019-02-13 02:07:58 -0800
committerJosh Ellithorpe2019-02-13 02:07:58 -0800
commite55fdc3a90a6406dad184829006fdee5428056ee (patch)
treee50395e606dd5b2f4a31797d21ba61519b14fb86 /PKGBUILD
downloadaur-e55fdc3a90a6406dad184829006fdee5428056ee.tar.gz
Add CashShuffle to the AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1d72792c24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Josh Ellithorpe <quest at mac dot com>
+
+pkgname=cashshuffle
+pkgver=0.4.3
+pkgrel=0
+pkgdesc="CashShuffle server for BCH."
+arch=('i686' 'x86_64')
+url="http://github.com/cashshuffle/cashshuffle"
+license=('MIT')
+makedepends=('go' 'git')
+options=('!strip' '!emptydirs')
+provides=("s=${pkgver}")
+source=("https://github.com/cashshuffle/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('1b8acd595a9589ac0f42590f7ba8936b33ddfc4c4e6c1b9e5819a0ff324ab634')
+
+build() {
+ mkdir -p "${srcdir}/go/src/github.com/cashshuffle"
+ export GOPATH="${srcdir}/go"
+ export GOBIN="$GOPATH/bin"
+
+ mv "$pkgname-$pkgver" "$GOPATH/src/github.com/cashshuffle/cashshuffle"
+ cd "$GOPATH/src/github.com/cashshuffle/cashshuffle"
+
+ go get -u github.com/FiloSottile/gvt
+ $GOBIN/gvt restore
+
+ go build .
+}
+
+package() {
+ cd "${srcdir}/go/src/github.com/cashshuffle/cashshuffle"
+
+ install -Dm 775 "cashshuffle" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 644 "LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}