summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikita Puzyryov2017-07-23 03:36:12 +0300
committerNikita Puzyryov2017-07-23 03:36:12 +0300
commit326b29f60ed71c3855c8d0ff386fed2d56e4acbe (patch)
tree810896ef4909597aa21d60199a57706d09dc6565 /PKGBUILD
parent47704634aa95e0d6ee5579e02cec2fd93ce4a18a (diff)
downloadaur-326b29f60ed71c3855c8d0ff386fed2d56e4acbe.tar.gz
Update deps
Apparently `mesontest` is the canonical way to execute tests.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 008d5a1a391d..c759b9b5c967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Nikita Puzyryov <PuzyryovN@gmail.com>
pkgname=casync-git
-pkgver=1.r17.ge1877ff
+pkgver=1.r87.g267a1b0
pkgrel=1
pkgdesc="Content-Addressable Data Synchronization Tool"
arch=(x86 x86_64)
url="https://github.com/systemd/casync"
license=('LGPL')
-depends=('acl' 'libcurl.so' 'libgcrypt' 'xz' 'fuse2')
-makedepends=('git' 'meson')
+depends=('acl' 'libcurl.so' 'openssl' 'xz' 'fuse2' 'libselinux')
+makedepends=('git' 'meson' 'python-sphinx')
optdepends=()
checkdepends=('rsync')
provides=('casync')
@@ -30,8 +30,8 @@ build() {
}
check() {
- cd "$srcdir/$pkgname"
- ninja -C build/ test
+ cd "$srcdir/$pkgname/build"
+ mesontest
}
package() {