summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgileri2022-05-24 23:52:05 +0200
committergileri2022-05-25 00:02:13 +0200
commita833b438ba376440920aedf3f36a3bd50ddceb4d (patch)
tree9c1037f4dceb401be3f8d06fab856d721e7a0a62 /PKGBUILD
parent7110756ed3f0fc3ae80e51c4f153321b5afea1b6 (diff)
downloadaur-a833b438ba376440920aedf3f36a3bd50ddceb4d.tar.gz
Patch Makefile to ignore array-bounds checks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61987d9c756c..00a9bf11fff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Klemen Košir <klemen913@gmail.com>
pkgname=cataclysm-dda-git
-pkgver=0.F.2022.02.22
+pkgver=0.F.2022.05.24
_pkgver=0.F
pkgrel=1
pkgdesc="A post-apocalyptic roguelike."
@@ -25,8 +25,12 @@ optdepends=('sdl2_image: for tiles'
# The git repo is more than a GB
# so download a snapshot while waiting for shallow clone support in makepkg
# (you may uncomment the alternate source/pkgver() if you would prefer to use that)
-source=('https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip')
-md5sums=('SKIP')
+source=(
+ 'https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip'
+ "disable_bound_check.patch"
+)
+sha512sums=('SKIP'
+ '8f4324dc935d3db98a7d5a12b46f2c58c37b6b4b4f2cbcdacc0462b1efa89f191d9fd7a0c8280c21d0abc0d448f66dad015cde7686f498ed4d5ae3d20a0521b1')
pkgver() {
cd "Cataclysm-DDA-master"
@@ -38,6 +42,7 @@ pkgver() {
prepare() {
cd "Cataclysm-DDA-master"
sed -i 's/ncursesw5-config/ncursesw6-config/' Makefile
+ patch --strip 1 < "${srcdir}/disable_bound_check.patch"
}
build() {