summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVi0L02016-08-15 17:42:22 +0200
committerVi0L02016-08-15 17:42:22 +0200
commit392aac083a35ea9c826764ca24a65545889117ac (patch)
tree8a899133fa456554ac6369a54d98c68a6ad2c458 /PKGBUILD
parent9b02db784c586f4651bd16e448a4faf3bc155fa0 (diff)
downloadaur-392aac083a35ea9c826764ca24a65545889117ac.tar.gz
15.9-12: 4.7 kernel support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c52078bd5bbb..03e6b00d7af8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,13 @@ _kernver=`uname -r`
pkgname=catalyst
pkgver=15.9
-pkgrel=11
+pkgrel=12
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-depends=('linux>=3.0' 'linux<4.7' 'catalyst-utils')
+depends=('linux>=3.0' 'linux<4.8' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
conflicts=('catalyst-test')
install=catalyst.install
@@ -43,7 +43,8 @@ source=(
crimson_i686_xg.patch
4.4-manjaro-xstate.patch
grsec_arch.patch
- 4.6-arch-get_user_pages-page_cache_release.patch)
+ 4.6-arch-get_user_pages-page_cache_release.patch
+ 4.7-arch-cpu_has_pge-v2.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd98b7e486d7fd4cad8de7b95b5b031e'
@@ -57,7 +58,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'6cdbaf5f71d867d225721a0369413616'
'd9bea135ae3e1b3ca87c5bbe6dcf8e72'
'8941e91fc58cb44ce21ab9bda135754e'
- '11b7c2e0dc4794801005d66b0e7608a3')
+ '11b7c2e0dc4794801005d66b0e7608a3'
+ '37eef5103a11d8136979463e7bc31091')
build() {
@@ -91,6 +93,7 @@ build() {
patch -Np1 -i ../4.4-manjaro-xstate.patch
patch -Np1 -i ../grsec_arch.patch
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
+ patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
cd ${srcdir}/archive_files/common/lib/modules/fglrx/build_mod
cp ${srcdir}/archive_files/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a .