summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVi0L02016-12-11 20:41:56 +0100
committerVi0L02016-12-11 20:41:56 +0100
commit955d85a7f5062653200d19df1864887efa48b2e7 (patch)
treed0a87d6ade64de2373a6274ae9e8720dde0b5c09 /PKGBUILD
parent67bb4624cba5dde441539fd351922b6bf64750cf (diff)
downloadaur-955d85a7f5062653200d19df1864887efa48b2e7.tar.gz
15.9-14: initial 4.9 kernel support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa6f25ba04d7..a4944dbe4cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,13 @@ _kernver=`uname -r`
pkgname=catalyst
pkgver=15.9
-pkgrel=13
+pkgrel=14
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-depends=('linux>=3.0' 'linux<4.9' 'catalyst-utils')
+depends=('linux>=3.0' 'linux<4.10' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
conflicts=('catalyst-test')
install=catalyst.install
@@ -44,7 +44,8 @@ source=(
4.4-manjaro-xstate.patch
grsec_arch.patch
4.6-arch-get_user_pages-page_cache_release.patch
- 4.7-arch-cpu_has_pge-v2.patch)
+ 4.7-arch-cpu_has_pge-v2.patch
+ 4.9_over_4.6-arch-get_user_pages_remote.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd98b7e486d7fd4cad8de7b95b5b031e'
@@ -59,7 +60,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'd9bea135ae3e1b3ca87c5bbe6dcf8e72'
'8941e91fc58cb44ce21ab9bda135754e'
'11b7c2e0dc4794801005d66b0e7608a3'
- '37eef5103a11d8136979463e7bc31091')
+ '37eef5103a11d8136979463e7bc31091'
+ '194cb44e9e2ab0e65b6267aca66d0400')
build() {
@@ -94,6 +96,7 @@ build() {
patch -Np1 -i ../grsec_arch.patch
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
+ patch -Np1 -i ../4.9_over_4.6-arch-get_user_pages_remote.patch
cd ${srcdir}/archive_files/common/lib/modules/fglrx/build_mod
cp ${srcdir}/archive_files/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a .