summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVi0L02016-06-08 21:48:39 +0200
committerVi0L02016-06-08 21:48:39 +0200
commit9b02db784c586f4651bd16e448a4faf3bc155fa0 (patch)
tree57d30942e58f9cfc14a98c3a343c39c825060218 /PKGBUILD
parent0841f3d275560f5063dc650b72ec7df9ee4b18b8 (diff)
downloadaur-9b02db784c586f4651bd16e448a4faf3bc155fa0.tar.gz
15.9-11: 4.6 kernel support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6efcc26b3c40..c52078bd5bbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,19 +9,20 @@
# Contributor: zoopp
# Contributor: kolasa (part of 4.3 kernel patches)
# Contributor: gentoo (part of 4.3 kernel patches)
+# Contributor: Philip Muller @ Manjaro (4.4 kernel patch)
_kernver=`uname -r`
pkgname=catalyst
pkgver=15.9
-pkgrel=10
+pkgrel=11
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-depends=('linux>=3.0' 'linux<4.6' 'catalyst-utils')
+depends=('linux>=3.0' 'linux<4.7' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
conflicts=('catalyst-test')
install=catalyst.install
@@ -41,7 +42,8 @@ source=(
4.2-amd-from_crimson_15.11.patch
crimson_i686_xg.patch
4.4-manjaro-xstate.patch
- grsec_arch.patch)
+ grsec_arch.patch
+ 4.6-arch-get_user_pages-page_cache_release.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd98b7e486d7fd4cad8de7b95b5b031e'
@@ -54,7 +56,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd2851026228ca72124972d1ea0335ea'
'6cdbaf5f71d867d225721a0369413616'
'd9bea135ae3e1b3ca87c5bbe6dcf8e72'
- '8941e91fc58cb44ce21ab9bda135754e')
+ '8941e91fc58cb44ce21ab9bda135754e'
+ '11b7c2e0dc4794801005d66b0e7608a3')
build() {
@@ -87,6 +90,7 @@ build() {
test "${CARCH}" = "i686" && patch -Np1 -i ../crimson_i686_xg.patch
patch -Np1 -i ../4.4-manjaro-xstate.patch
patch -Np1 -i ../grsec_arch.patch
+ patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
cd ${srcdir}/archive_files/common/lib/modules/fglrx/build_mod
cp ${srcdir}/archive_files/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a .