summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVi0L02015-10-04 12:17:11 +0200
committerVi0L02015-10-04 12:17:11 +0200
commit413a266147edfd527297ccfebf0d813eeaab85c5 (patch)
treede8c2f97df3969b2b2684c21cd03bbbfb3c05b07 /PKGBUILD
parentcf2557601c4908c69b9340fec4cc83f3fc20336e (diff)
downloadaur-413a266147edfd527297ccfebf0d813eeaab85c5.tar.gz
adding another patch for 4.2 kernel support, still not working
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 455145bd7c1c..2e1b040deb2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,8 +39,7 @@ optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
'acpid: acpi event support / atieventsd'
- 'procps-ng: brings pgrep used in acpi event support'
- 'linux-lts-headers: to build the fglrx module for the linux-lts kernel')
+ 'procps-ng: brings pgrep used in acpi event support')
conflicts=('libgl' 'catalyst' 'catalyst-daemon' 'catalyst-generator' 'catalyst-hook' 'catalyst-utils' 'libcl' 'catalyst-dkms' 'mesa-libgl' 'mesa-libgl-git')
provides=('libgl' "libatical=${pkgver}" "catalyst=${pkgver}" "catalyst-utils=${pkgver}" "catalyst-hook=${pkgver}" "catalyst-libgl=${pkgver}" "opencl-catalyst=${pkgver}" 'libcl' 'dri' 'libtxc_dxtn' 'mesa-libgl' 'mesa-libgl-git')
@@ -90,15 +89,13 @@ source=(
temp-links-catalyst.service
lano1106_fglrx_intel_iommu.patch
lano1106_kcl_agp_13_4.patch
- lano1106_fglrx-13.8_proc.patch
- cold-fglrx-3.14-current_euid.patch
fglrx_gpl_symbol.patch
- fglrx_3.17rc6-no_hotplug.patch
ubuntu_buildfix_kernel_4.0.patch
ubuntu_buildfix_kernel_4.1.patch
ubuntu_buildfix_kernel_4.2.patch
4.2-fglrx-has_fpu.patch
- 4.2-kolasa-fpu_save_init.patch)
+ 4.2-kolasa-fpu_save_init.patch
+ ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'601d9c756571dd79d26944e54827631e'
@@ -122,15 +119,13 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'2c22bb4d4f828cb8b024f670c1ae7e45'
'5184b94a2a40216a67996999481dd9ee'
'c5156eddf81c8a1719b160d05a2e8d67'
- '2ab4837233de42332753882445373d7b'
- 'ba33b6ef10896d3e1b5e4cd96390b771'
'ef97fc080ce7e5a275fe0c372bc2a418'
- '67a22f624bae95a76638ce269392cb01'
'880d5e59554cda382f74206c202942be'
'982451bcc1fa1ee3da53ffa481d65581'
'88832af8d6769aa51fa9b266a74394e0'
'ed7748a593d6b894269f8c7856b7ae50'
- 'dd51495a1d8f2d1042f04a783bf01e08')
+ 'dd51495a1d8f2d1042f04a783bf01e08'
+ '2f7d42fde403a1b4a22e5db8de738d0f')
build() {
@@ -312,17 +307,15 @@ package() {
patch -Np1 -i ../makefile_compat.patch
patch -Np1 -i ../lano1106_fglrx_intel_iommu.patch
patch -Np1 -i ../lano1106_kcl_agp_13_4.patch
-# patch -Np1 -i ../lano1106_fglrx-13.8_proc.patch
-# patch -Np1 -i ../cold-fglrx-3.14-current_euid.patch
-# patch -Np1 -i ../fglrx_3.17rc6-no_hotplug.patch
# test "${CARCH}" = "i686" && patch -Np1 -i ../fglrx_gpl_symbol.patch
# since 3.19 not only i686 needs gpl symbol - V
patch -Np1 -i ../fglrx_gpl_symbol.patch
patch -Np1 -i ../ubuntu_buildfix_kernel_4.0.patch
patch -Np1 -i ../ubuntu_buildfix_kernel_4.1.patch
- patch -Np1 -i ../ubuntu_buildfix_kernel_4.2.patch #three 4.2 patches left for testing purposes, use simultaneously - V
+ patch -Np1 -i ../ubuntu_buildfix_kernel_4.2.patch
patch -Np1 -i ../4.2-fglrx-has_fpu.patch
patch -Np1 -i ../4.2-kolasa-fpu_save_init.patch
+ patch -Np1 -i ../ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch
# Prepare modules source files
_archdir=x86_64