summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVi0L02018-07-01 21:49:45 +0200
committerVi0L02018-07-01 21:49:45 +0200
commitc1992a5a85c72954480d822a6ab638053c8c0269 (patch)
tree67d27882b7c95ae16d38acb82653343e37bb6617 /PKGBUILD
parentd3b05f3ad73a2b3e3cc86ca52f6a137eaa106596 (diff)
downloadaur-c1992a5a85c72954480d822a6ab638053c8c0269.tar.gz
15.12-25: 4.17 kernel support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a41ae46a276d..9340bd0ba744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,21 +24,21 @@
# Contributor: aslmaswd (acpi main script)
# Contributor: npfeiler (libcl/opencl-icd-loader cleaning)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (4.11, 4.12, 4.13, 4.14 and 4.15.5 kernel patch)
+# Contributor: npfeiler (4.11, 4.12, 4.13, 4.14, 4.15.5 and 4.17 kernel patch)
_old_control=n #for pre-GCN users who has problems with default config, pick =y to use control file and opencl runtime from catalyst 15.9
pkgname=catalyst-test
pkgver=15.12
-pkgrel=24
+pkgrel=25
# _betano=1.0
_amdver=15.302
pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.17' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
+options=('staticlibs' 'libtool' '!strip')
+depends=('dkms' 'linux>=3.0' 'linux<4.18' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -108,7 +108,8 @@ source=(
4.12-npfeiler-movsl_mask.patch
4.13-npfeiler-wait_queue_t.patch
4.14-npfeiler-task_struct-mm_segment_t.patch
- 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch)
+ 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
+ 4.17-npfeiler-pci_get_domain_bus_and_slot.patch)
md5sums=('39808c8a9bcc9041f1305e3531b60622'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -145,7 +146,8 @@ md5sums=('39808c8a9bcc9041f1305e3531b60622'
'cb25bc7fbb7d5cb1c07d2f3fa5fda826'
'0a725f40bc980d578cbed3e57a05b765'
'5ba3bf9f58aa63c1849b056cf23022c9'
- '10af58c21e4e972115dda6dbd8279594')
+ '10af58c21e4e972115dda6dbd8279594'
+ '7ed6e1cf3a9719e6a9874e6a18f29bfb')
if [ "${_old_control}" = "y" ]; then
source+=(https://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip)
@@ -186,6 +188,7 @@ prepare() {
patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
patch -Np1 -i ../4.14-npfeiler-task_struct-mm_segment_t.patch
patch -Np1 -i ../4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
+ patch -Np1 -i ../4.17-npfeiler-pci_get_domain_bus_and_slot.patch
cd ${srcdir}/archive_files/common
patch -Np2 -i ${srcdir}/arch-fglrx-authatieventsd_new.patch