summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorclintval2018-05-07 14:23:20 -0700
committerclintval2018-05-07 14:23:20 -0700
commitda2e1a781ef17a49931d1a87fe59225a694aef1a (patch)
tree1bebebf2299d45527fb900420627e828fe5013af /PKGBUILD
downloadaur-da2e1a781ef17a49931d1a87fe59225a694aef1a.tar.gz
First commit with PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beb0a9dd9777
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='catt'
+pkgver=0.6.1
+pkgrel=1
+pkgdesc='Send videos from many, many online sources to your Chromecast'
+arch=('any')
+url=https://github.com/skorokithakis/"${pkgname}"
+license=('BSD')
+depends=(
+ 'python'
+ 'python-click'
+ 'python-pychromecast'
+ 'youtube-dl')
+makedepends=('python' 'python-setuptools')
+source=("${pkgname}"-"${pkgver}".tar.gz::https://github.com/skorokithakis/"${pkgname}"/archive/v"${pkgver}".tar.gz)
+sha256sums=('01170e82eb9f51b9d844735ee8a3ae4f9e1d3544676f126cbee8b06d15398f5e')
+
+build(){
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ install -Dm644 README.rst "${pkgdir}"/usr/share/doc/"${pkgname}"/README.rst
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}