summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCelestialWalrus2015-07-16 05:01:46 -0400
committerCelestialWalrus2015-07-16 05:01:46 -0400
commit886e8ef95e6e048c2e45c3350ff77583618e246d (patch)
tree2b9cb293514d3df5e9ba262fc3f25e31c65691f2 /PKGBUILD
downloadaur-886e8ef95e6e048c2e45c3350ff77583618e246d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..117571705717
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Celestial Walrus <aur@celestial.cf>
+
+pkgname=cava
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Console-based Audio Visualizer for Alsa'
+arch=(i686 x86_64)
+url='https://github.com/karlstav/cava'
+license=(none)
+depends=(glibc)
+makedepends=(fftw)
+source=(https://github.com/karlstav/cava/archive/${pkgver}.tar.gz)
+sha1sums=('f7def5df6541042bbbaacf324114753151655095')
+
+build() {
+ cd $pkgname-$pkgver
+ make VERSION="${pkgver}"
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 cava "$pkgdir/usr/bin/cava"
+}