summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2023-02-11 02:17:50 +0100
committerBalló György2023-02-11 02:17:50 +0100
commit5d904837a2409cf9d6b73b7349746a3b05df5510 (patch)
treeb60582eb5ff6cbf6abd89d76ccd6e1b5fbaad21d /PKGBUILD
parentcd6e5e5656d439c50038d444977c45ccf1a1ee75 (diff)
downloadaur-5d904837a2409cf9d6b73b7349746a3b05df5510.tar.gz
Move cawbird from [community]
Twitter has banned Third Party clients, so can't acces the Twitter API, so development stopped: https://github.com/IBBoard/cawbird/issues/495
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cd187251b21..77757b2b7a1c 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=cawbird
-pkgver=1.0.5
-pkgrel=1
-pkgdesc="Native Gtk+ Twitter Client"
-arch=(i686 x86_64)
-license=(GPL3)
-url="https://ibboard.co.uk/cawbird/"
-depends=(gtk3 sqlite3 gspell
- gst-plugins-good gst-plugins-bad gst-libav gst-plugin-gtk)
-makedepends=(vala meson)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/IBBoard/cawbird/archive/v${pkgver}.tar.gz")
-sha256sums=('bdbb9baa4e2555e20bc46dc37c9627842fe1b53bd0d70520f9ab5636024204dc')
+pkgver=1.5
+pkgrel=2
+pkgdesc='Native GTK Twitter client'
+arch=('x86_64')
+url='https://ibboard.co.uk/cawbird/'
+license=('GPL3')
+depends=('gspell' 'gst-libav' 'gst-plugin-gtk' 'gst-plugins-bad' 'gst-plugins-good' 'liboauth' 'rest')
+makedepends=('meson' 'vala')
+source=("https://github.com/IBBoard/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('0ef472cbecd6a7eb384a5b27833612d61eba7ace22293dbe14571b887b61ecae')
build() {
- cd "$pkgname-$pkgver"
- meson _build --prefix=/usr
- ninja -C _build
+ arch-meson $pkgname-$pkgver build \
+ -D consumer_key_base64=YUVNOE14dE5xMVdHRzl2emo5SzNNSlNUeg== \
+ -D consumer_secret_base64=c0J0cmc2clNJTFN6bHlSbFNXc2J1MmdvWWk3b0FzTGZHOGI4OG5QRzB3Tmx1Y0ZtOHQ=
+ meson compile -C build
}
package() {
- cd "$pkgname-$pkgver"
- DESTDIR="${pkgdir}" ninja -C _build install
+ meson install -C build --destdir "$pkgdir"
}