summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 11:34:03 +0800
committerDaniel YC Lin2015-06-13 11:34:03 +0800
commitab22f323a2adb6b74395782375ebe3493f009290 (patch)
treee6be483e5b9d7138730b903c65480681a1e3ebb7 /PKGBUILD
downloadaur-ab22f323a2adb6b74395782375ebe3493f009290.tar.gz
merge to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23b797251ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel YC Lin <dlin at gmail>
+# Contributor: sssslang <xofyarg at gmail>
+# Contributor: kumkee <kumkee at gmail>
+pkgname=ccal
+pkgver=2.5.3
+pkgrel=2
+pkgdesc="A console program which writes a calendar together with Chinese calendar to standard output."
+arch=('i686' 'x86_64' sh4)
+url="http://ccal.chinesebay.com/ccal/ccal.htm"
+license="GPL"
+depends=('gcc-libs' 'bash')
+makedepends=('gcc')
+source=(http://ccal.chinesebay.com/ccal/$pkgname-$pkgver.tar.gz)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ mkdir -p $pkgdir/{usr/bin,usr/share/man/man1}
+ install -c ccal $pkgdir/usr/bin
+ install -c ccalpdf $pkgdir/usr/bin
+ install -c -m 0644 ccal.1 $pkgdir/usr/share/man/man1
+ install -c -m 0644 ccalpdf.1 $pkgdir/usr/share/man/man1
+}
+sha1sums=('b44d73804ef3ba9129ae196887509f99b508401c')