summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:42:33 +0200
committerAlexander F Rødseth2015-06-10 14:42:33 +0200
commitb2b2062b0c393efc3b68af1cc43c638b7b050a7a (patch)
treed582a7486e5f57d0b905cd932719af642a60379f /PKGBUILD
downloadaur-b2b2062b0c393efc3b68af1cc43c638b7b050a7a.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ac847a0b6e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+pkgname=ccode-git
+pkgver=20110326
+pkgrel=1
+pkgdesc="ViM autocompletion for C"
+url="https://github.com/nsf/ccode"
+arch=('x86_64' 'i686')
+license=('MIT')
+depends=('clang')
+makedepends=('git')
+_gitroot="git://github.com/nsf/ccode.git"
+_gitname="ccode"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to github.com GIT server...."
+ if [[ -d $_gitname ]] ; then
+ ( cd "$_gitname" && git pull origin )
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot"
+ fi
+ msg "GIT checkout done or server timeout"
+
+ rm -rf "$_gitname-build"
+ git clone "$_gitname" "$_gitname-build"
+ cd "$_gitname-build"
+
+ msg2 "Building..."
+ head -2 update.bash > compile.bash
+ chmod +x compile.bash
+ ./compile.bash
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ msg2 "Packaging..."
+ install -Dm755 ccode "$pkgdir/usr/bin/ccode"
+ install -Dm644 vim/plugin/ccode.vim \
+ "$pkgdir/usr/share/vim/vimfiles/plugin/ccode.vim"
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+# vim:set ts=2 sw=2 et: