summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlizr20042018-12-21 20:02:49 +0800
committerlizr20042018-12-21 20:02:49 +0800
commit797c99eda8108f8818bb40223e35e07c636efe25 (patch)
tree28c901176814e200a7a4ecb26a18eaa1824ffa3d /PKGBUILD
parent1b0bb24bee2fca04ff0d7941bb14ef694327c740 (diff)
downloadaur-797c99eda8108f8818bb40223e35e07c636efe25.tar.gz
crazy chmod fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 466412d766db..3f552fd093bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: equation314 <https://github.com/equation314>
pkgname=ccrplus
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A opensource and cross-platform judge environment for OI contest."
arch=('x86_64')
url="https://github.com/sxyzccr/CCR-Plus"
@@ -13,14 +13,14 @@ md5sums=() #autofill using updpkgsums
prepare() {
cd "$srcdir"
- if [ -e CCR-Plus ]; then
- cd CCR-Plus
- git pull
- else
- git clone https://github.com/sxyzccr/CCR-Plus
- fi
- # FIXME: Complie Error because of less header file
- sed -i "4 i #include <QHeaderView>" "$srcdir/CCR-Plus/src/configure/configuredialog.h"
+ if [ -e CCR-Plus ]; then
+ cd CCR-Plus
+ git pull
+ else
+ git clone https://github.com/sxyzccr/CCR-Plus
+ cd CCR-Plus
+ fi
+ git apply $srcdir/../ccr-plus.patch
}
build() {