summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothy Redaelli2015-08-18 20:03:05 +0200
committerTimothy Redaelli2015-08-18 20:03:09 +0200
commit18e5e3314d2406e33aed5bbbffb2f680d01109d4 (patch)
tree7a86ea47b7dadfca22ecfa7a76c4189c73ec5f8f /PKGBUILD
downloadaur-18e5e3314d2406e33aed5bbbffb2f680d01109d4.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd88bc7c468f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Jeff Mickey <jeff@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=ccrtp
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="An implementation of RTP, the real-time transport protocol from the IETF"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/ccrtp/"
+license=('GPL' 'custom')
+depends=('ucommon' 'libgcrypt')
+install=$pkgname.install
+source=("http://dev.gnutelephony.org/dist/tarballs/$pkgname-$pkgver.tar.gz"{,.sig})
+md5sums=('e6792cbd8b705901c205a509bd7f812f'
+ 'SKIP')
+validpgpkeys=('3D937C85BF4A787DF6C7247DFC531209EA8888AD')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 COPYING.addendum "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}