summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2016-03-28 07:56:29 -0700
committerShadowKyogre2016-03-28 09:27:09 -0700
commita5c08f5562efcf79167fbe95e99a344d009d4b06 (patch)
treee9008b953f79cf0154db59e12b6e1c9e394c4425 /PKGBUILD
parent1925ce877ed13e2c276fd606692c147be380f1b7 (diff)
downloadaur-a5c08f5562efcf79167fbe95e99a344d009d4b06.tar.gz
Update to point to github repos
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9eb8d7a576e4..476205e08952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,30 @@
# Contributor: nesl247 <nesl247@gmail.com>
pkgname=ccsm-git
-pkgver=0.8.10.r2.g4a1bedd
+pkgver=0.8.12.2.r0.gef02e91
pkgrel=1
pkgdesc="Compizconfig Settings Manager in Python2"
arch=('any')
-url="http://git.northfield.ws/compiz/?p=compiz/ccsm;a=summary"
+url="https://github.com/compiz-reloaded/ccsm"
license=('GPL')
-depends=("compizconfig-python-git" 'pygtk')
+depends=("compizconfig-python-git" 'gobject-introspection')
makedepends=('intltool')
-optdepends=('compiz-gtk-standalone: option 1' 'compiz-core: option 2' 'python2-sexy: needed for some widgets')
+optdepends=('compiz-gtk-standalone: option 1' 'compiz-core: option 2')
groups=('compiz-fusion' 'compiz-fusion-gtk' 'compiz-fusion-kde')
conflicts=('ccsm')
provides=("ccsm=$pkgver")
source=(
- 'git://northfield.ws/compiz/ccsm'
+ 'git+https://github.com/compiz-reloaded/ccsm.git'
)
install=ccsm.install
sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
cd "${srcdir}/${pkgname%%-git}"
- python2 ./setup.py install --prefix=/usr --root="${pkgdir}"
+ python2 ./setup.py install --prefix=/usr --with-gtk=2.0 --root="${pkgdir}"
}